/routing/bgp/connection

connection

所有连接特定参数的列表可在下表中查看。


routing/bgp/connection

Conditions: !smips Type: Directory

所有连接特定参数的列表可在下表中查看。

除了连接特定参数外,此菜单还直接公开模板特定参数,以便在简单场景(不需要模板时)中更轻松地配置。

标志名称描述
Ddynamic动态
Xdisabled已禁用
Iinactive未激活
参数类型描述
name *string
instance *enum
remote.addressaddress (flags=46i/+:)用于连接和/或监听的远程地址。
remote.portnum
remote.assuper { as: as , [sub-as] [ /as] }远程 AS 号。如果未指定,BGP 将从 OPEN 消息中自动确定远程 AS。
remote.ttlnum可接受的最小生存时间,即此 TCP 连接的跳数限制。例如,如果 'ttl=255',则只有单跳邻居能够建立连接。此属性仅影响 EBGP 对等体。
remote.allowed-asenum包含允许连接的远程 AS 号的 num-list 名称。对于动态对等体配置很有用。
local.addressaddress (flags=46i:)
local.portnum
local.ttlnum将记录在发送的 TCP 数据包中的生存时间(跳数限制)。
local.role *enum (ibgp | ibgp-rr | ebgp | ebgp-provider | ebgp-rs | ebgp-rs-client | ebgp-customer | ebgp-peer)BGP 角色。在大多数场景中设置为 iBGP 或 eBGP。有关 BGP 角色和路由泄露防护的更多信息,请参见路由泄露防护以及相应的 RFC 9234。
tcp-md5-keystring用于通过 RFC 2385 所述的 TCP MD5 签名验证连接的密钥。留空以禁用身份验证。
connectbool是否允许路由器发起连接。
listenbool启用监听传入连接。如果 remote.address 是主机地址且启用了监听,则在首次成功接受后关闭监听套接字。如果 remote.address 是子网且启用了监听,则在首次成功接受后监听套接字保持打开,硬编码限制为 256 个打开连接。
routing-tableenum用于安装路由的路由表名称。覆盖实例参数。
vrfenumBGP 连接所在的 VRF 名称。默认使用“main”路由表。
templatesmulti { template: enum }用于继承参数值的模板名称列表。这是一项有用的功能,可轻松配置具有重叠配置选项的组。
asas32 位 BGP 自治系统号。该值接受 AS-Plain 或 AS-Dot 格式。覆盖实例 ASN,并使用以下格式配置 BGP 联盟:confederation_as/as。例如,如果您的 AS 为 34,联盟 AS 为 43,请设置 as=43/34。
nexthop-choiceenum (default | force-self | propagate)影响出站 NEXT_HOP 属性的选择。过滤器中设置的下一跳始终优先,并且在路由反射时不会更改,除非在过滤器中设置。 default - 按 RFC 4271 所述选择下一跳 force-self - 使用连接到对等体的接口的本地地址作为下一跳 propagate - 传播接收到的下一跳;如果路由具有 BGP NEXT_HOP 属性,则将其用作下一跳;否则回退到默认情况
multihopbool当远程对等体相隔多跳时启用。此选项影响出站下一跳选择,如 RFC 4271 所述(仅适用于 eBGP,不包括联盟本地的 iBGP 对等体)。它还影响:是否接受来自不在同一网络中的对等体的连接(此检查使用连接的远程地址);是否接受 NEXT_HOP 属性与建立连接所用地址不在同一网络中的传入路由;从此对等体安装的路由的目标作用域;来自多跳或 iBGP 对等体的路由默认通过 IGP 路由解析其下一跳
hold-timealt { special: enum (infinity) { infinity:0 } , number: time [3 .. 65535] }指定与对等体协商时使用的 BGP 保持时间值。根据 BGP 规范,如果路由器在 OPEN 消息的 Hold Time 字段指定的时间内未收到连续的 KEEPALIVE 和/或 UPDATE 和/或 NOTIFICATION 消息,则到该对等体的 BGP 连接将被关闭。将使用两个对等体中最小的 hold-time 值(请注意特殊值 0 或“infinity”低于任何其他值)* infinity - 永不过期连接,也从不发送 keepalive 消息。
keepalive-timetimekeepalive 消息之间的间隔,如果未设置,则默认 keepalive 为 hold-time 的 1/3。
afiubit (ip, ipv6, l2vpn, l2vpn-cisco, vpnv4, vpnv6, evpn)此对等体可以交换路由信息的地址族列表。远程对等体必须支持 BGP 能力可选参数(通常都支持),才能协商 IP 以外的任何地址族。
cisco-vpls-nlri-len-fmtenum (auto-bits | auto-bytes | bits | bytes)VPLS NLRI 长度格式类型。用于与 Cisco VPLS 兼容。[[了解更多>>]]。
output.remove-private-asbool如果设置,则当 BGP AS-PATH 属性仅包含私有 AS 号时,在发送路由更新之前移除该属性。移除过程在应用路由过滤器之前、以及在本地 AS 号前置于 AS 路径之前进行。
output.as-overridebool如果设置,则在向该对等体发送路由更新之前,将 BGP AS-PATH 属性中远程对等体 AS 号的所有实例替换为本地 AS 号。此操作在路由过滤器和前置操作之前进行。
use-bfdbool是否使用 BFD 协议以更快检测连接状态。
save-tostring将 BGP 协议特定数据包内容(导出的 PDU)保存为 pcap 格式的文件名。此方法可为调试目的提供更简单的对等体特定数据包捕获。
output.add-pathubit (ip, ipv6)启用为指定地址族发送额外路径(BGP Addpath)。
output.affinityenum (main | alone | remote-as | instance | afi | vrf | input)配置输出多核处理。更多内容参见路由协议多核支持一文。 alone - 每个会话的输入和输出在各自进程中处理,在有大量核心和大量对等体时最可能是最佳选项 afi, instance, vrf, remote-as - 尝试在具有相似参数的进程中运行新会话的输入/输出 main - 在主进程中运行输入/输出(在单核上,甚至在核心数较少的多核设备上,可能提高性能) input - 在与输入相同的进程中运行输出(仅可为输出亲和性设置)
output.redistributeubit (connected, static, rip, ospf, isis, bgp, vpn, dhcp, fantasy, modem, bgp-mpls-vpn, slaac)启用指定路由类型的重分发。
output.filter-selectenum用于前缀选择的路由选择链名称。如果未指定,则使用默认选择。
output.filter-chainenum用于输出前缀的路由过滤器链名称。如果未指定链,则 BGP 默认接受所有内容。
output.networkenum用于发送本地网络的地址列表名称。仅当路由表中存在匹配的 IGP 路由且其 ORIGIN 属性设置为 IGP 时,才发送该网络;其他分发方法的 ORIGIN 属性设置为 INCOMPLETE。
output.network-blackholebool
output.default-originateenum (never | if-installed | always)指定默认路由(0.0.0.0/0)的分发方法。'if-installed' 选项可用于仅在路由表中存在相应 IGP 路由时分发默认路由。
output.default-prependnum本地 ASN 前置的次数。
output.no-client-to-client-reflectionbool在路由反射器设置中禁用客户端到客户端的路由反射。
output.no-early-cutbool提前裁剪是一种机制,用于(基于默认 RFC 行为)推测发送的 NLRI 被远程对等体接收时会发生什么。如果算法确定该 NLRI 将被丢弃,对等体甚至不会尝试发送它。然而在特定场景中可能不希望这种行为,此时应使用此选项禁用提前裁剪功能。提前裁剪适用于 eBGP 会话。
output.keep-sent-attributesbool在内存中存储已发送前缀的属性,dump-saved-advertisements 命令需要此功能才能工作。默认情况下,为节省路由器内存,不会存储已发送的前缀。仅在需要查看当前通告前缀时出于调试目的启用此选项。
input.add-pathubit (ip, ipv6)接受指定地址族接收到的额外路径(BGP Addpath)。
input.attr-error-handlingenum (default | revised)
input.affinityenum (main | alone | remote-as | instance | afi | vrf)配置输入多核处理。更多内容参见路由协议多核支持一文。 - alone - 每个会话的输入和输出在各自进程中处理,在有大量核心和大量对等体时最可能是最佳选项。 - afi, instance, vrf, remote-as - 尝试在具有相似参数的进程中运行新会话的输入/输出。 - main - 在主进程中运行输入/输出(在单核上,甚至在核心数较少的多核设备上,可能提高性能)。
input.filterenum用于输入前缀的路由过滤器链名称。此操作在处理 NLRI 之后进行。如果未指定链,则 BGP 默认接受所有内容。
input.filter-nlrienum用于在传入 IPv4/IPv6 NLRI 被存储到内存之前直接过滤它们的过滤器链名称,从而显著减少内存使用。常规输入过滤器链只能拒绝前缀,这意味着它仍会占用内存,并会在 /routing route table 中显示为“not active, filtered”。应用更改需要重启会话。
input.allow-asnum指示在丢弃前缀之前允许自己的 AS 号在 AS-PATH 中出现多少次。
input.accept-nlrienumipv4/6 地址列表名称。这是一种使用特定 NLRI 过滤传入更新的快捷方式。它允许在传入消息被解析和存储到内存之前直接过滤,从而显著减少内存使用。常规输入过滤器链只能拒绝前缀,这意味着它仍会占用内存,并会在 /routing route table 中显示为“not active, filtered”。应用更改需要重启会话。
input.filter-communitiesenum使用特定 community 过滤传入更新的一种快捷方式。它允许在传入消息被解析和存储到内存之前直接过滤,从而显著减少内存使用。常规输入过滤器链只能拒绝前缀,这意味着它仍会占用内存,并会在 /routing route table 中显示为“not active, filtered”。应用更改需要刷新会话。
input.filter-ext-communitiesenum使用特定 extended community 过滤传入更新的一种快捷方式。它允许在传入消息被解析和存储到内存之前直接过滤,从而显著减少内存使用。常规输入过滤器链只能拒绝前缀,这意味着它仍会占用内存,并会在 /routing route table 中显示为“not active, filtered”。应用更改需要刷新会话。
input.filter-large-communitiesenum使用特定 large community 过滤传入更新的一种快捷方式。它允许在传入消息被解析和存储到内存之前直接过滤,从而显著减少内存使用。常规输入过滤器链只能拒绝前缀,这意味着它仍会占用内存,并会在 /routing route table 中显示为“not active, filtered”。应用更改需要刷新会话。
input.accept-communitiesenum使用特定 community 过滤传入更新的一种快捷方式。它允许在传入消息被解析和存储到内存之前直接过滤,从而显著减少内存使用。常规输入过滤器链只能拒绝前缀,这意味着它仍会占用内存,并会在 /routing route table 中显示为“not active, filtered”。应用更改需要刷新会话。
input.accept-ext-communitiesenum使用特定 extended community 过滤传入更新的一种快捷方式。它允许在传入消息被解析和存储到内存之前直接过滤,从而显著减少内存使用。常规输入过滤器链只能拒绝前缀,这意味着它仍会占用内存,并会在 /routing route table 中显示为“not active, filtered”。应用更改需要刷新会话。
input.accept-large-communitiesenum使用特定 large community 过滤传入更新的一种快捷方式。它允许在传入消息被解析和存储到内存之前直接过滤,从而显著减少内存使用。常规输入过滤器链只能拒绝前缀,这意味着它仍会占用内存,并会在 /routing route table 中显示为“not active, filtered”。应用更改需要刷新会话。
input.filter-unknownenum使用特定“unknown”属性过滤传入更新的一种快捷方式。它允许在传入消息被解析和存储到内存之前直接过滤,从而显著减少内存使用。常规输入过滤器链只能拒绝前缀,这意味着它仍会占用内存,并会在 /routing route table 中显示为“not active, filtered”。应用更改需要刷新会话。
input.limit-process-routes-ipv4enum (10 | 100 | 1000 | 10000 | 100000 | 1000000 | 10000000) { 10:10, 100:100, 1000:1000, 10000:10000, 100000:100000, 1000000:1000000, 10000000:10000000 }尝试将接收的 IPv4 路由数量限制为指定数量。此数字并不代表对等体将要安装到路由表中的确切路由数。如果达到限制,必须使用 BGP 会话 “clear” 命令重置标志。
input.limit-process-routes-ipv6enum (10 | 100 | 1000 | 10000 | 100000 | 1000000 | 10000000) { 10:10, 100:100, 1000:1000, 10000:10000, 100000:100000, 1000000:1000000, 10000000:10000000 }尝试将接收的 IPv6 路由数量限制为指定数量。此数字并不代表对等体将要安装到路由表中的确切路由数。如果达到限制,必须使用 BGP 会话 “clear” 命令重置标志。
只读参数类型描述
local.default-addressaddress (flags=46i:)