MPLS

MPLS 是一种使用标签实现更快数据包转发的路由技术,无需分析 IP 头。RouterOS 支持 MPLS 交换、LDP/RSVP-TE 协议、VPLS 与 MP-BGP VPN,但不包含某些特性。

MPLS 表示 MultiProtocol Label Switching(多协议标签交换)。MPLS 不像 IP 路由那样根据 IP 头字段(例如目标地址)与路由表作出转发决策,而是根据附加在数据包上的标签决定出接口与下一跳路由器。由于下一跳查找比路由查找(查找最长匹配前缀)更简单,这种方式加快了转发过程。

转发效率是 MPLS 的主要优势。但请注意,MPLS 转发会禁用网络层(例如 IP)头的处理。因此,无法对 MPLS 转发的数据包执行 NAT 与过滤等基于网络层的操作。请在 MPLS 云的入口或出口执行任何基于网络层的操作,首选入口方式。这样,你打算丢弃的流量不会穿越 MPLS 骨干网。

MPLS 通过为活动路由使用 LDP 协议分发标签来工作,带标签的数据包会沿与未打标签数据包相同的路径传输。当路由器沿某条路由转发未打标签数据包,并且已从下一跳收到该路由的标签时,它会为数据包压入标签并发送到下一跳,由下一跳在网络中继续交换。当路由器收到带有自己为某条路由分配的标签的数据包时,它会将数据包标签替换为从该路由下一跳收到的标签,并发送到下一跳。标签交换路径确保数据送达 MPLS 云出口点。MPLS 应用正是基于标签交换路径这一概念。

建立标签交换路径的另一种方式是使用 RSVP-TE 协议创建流量工程隧道(TE 隧道)。流量工程隧道允许显式路由的 LSP 以及基于约束的路径选择(约束包括接口属性与可用带宽)。

由于 MPLS 引入了复杂性与新协议,并为路由网络与桥接网络增加了不同概念,在生产网络部署 MPLS 前应深入理解 MPLS 概念。建议阅读:

信息

SMIPS 设备(hAP lite、hAP lite TC 与 hAP mini)不支持此功能。

支持的特性

RouterOS 支持以下 MPLS 相关特性:

  • 支持倒数第二跳弹出(penultimate hop popping)的 MPLS 交换。
  • IPv4 与 IPv6 的静态本地标签绑定。
  • IPv4 与 IPv6 的静态远程标签绑定。
  • 面向 IPv4 与 IPv6 的标签分发协议(RFC 3036、RFC 5036 与 RFC 7552):
    • 下游主动标签通告。
    • 独立标签分发控制。
    • 宽松标签保留。
    • 定向会话建立。
    • 可选环路检测。
    • ECMP 支持。
  • Virtual Private LAN Service(VPLS):
  • RSVP-TE 隧道:
    • 隧道头端。
    • 显式路径。
    • 面向 TE 隧道的 OSPF 扩展。
    • CSPF 路径选择。
    • 在 TE 隧道上转发 VPLS 与 MPLS IP VPN 流量。
    • 入口 TE 隧道速率限制与自动预留带宽调整。更多信息请参阅 流量工程。
    • 所有隧道带宽设置均以比特每秒为单位指定与显示。
  • 基于 MP-BGP 的 MPLS IP VPN。
  • 基于 MP-BGP 的 MPLS VPN 支持按前缀与按 VRF 的标签分发策略。
  • 面向 MPLS TE 的 OSPF 扩展。
  • 支持将 OSPF 用作 CE-PE 协议。
  • 针对指定 VRF 的 ping 与 traceroute。
  • 控制 MPLS 中的网络层 TTL 传播。
  • 支持将 RIP 用作 CE-PE 协议。
  • 按 VRF 的 BGP 实例重分发设置。

RouterOS 尚未提供的 MPLS 特性

  • LDP 特性:
    • 下游按需标签通告。
    • 有序标签分发控制。
    • 保守标签保留。
  • TE 特性:
    • 快速重路由(fast-reroute)。
    • 链路/节点保护。
  • 支持将 BGP 用作标签分发协议。