/routing/bgp/vpls
vpls
此菜单列出所有已配置的基于 BGP 的 VPLS 实例。这些实例允许路由器通告 VPLS BGP NLRI,并指示该路由器属于特定的客户 VPLS 网络。
routing/bgp/vpls
Conditions: !smips Type: Directory
此菜单列出所有已配置的基于 BGP 的 VPLS 实例。这些实例允许路由器通告 VPLS BGP NLRI,并指示该路由器属于特定的客户 VPLS 网络。
基于 MP-BGP 的自动发现和信令(RFC 4761)。
Cisco VPLS 基于 BGP 的自动发现(draft-ietf-l2vpn-signaling-08)。
支持基于 BGP 的 VPLS 的多个导入/导出路由目标扩展社区(RFC 4761 和 draft-ietf-l2vpn-signaling-08 均支持)。
| 标志 | 名称 | 描述 |
|---|---|---|
X | disabled | 已禁用 |
I | inactive | 未激活 |
| 参数 | 类型 | 描述 |
|---|---|---|
name | string | |
vrf | enum | |
rd | address (flags=R) | 指定附加到 VPLS NLRI 的值,以便接收路由器区分否则可能看起来相同的通告。这意味着必须为每个 VPLS 使用唯一的路由区分符。组成同一 VPLS 的所有路由器不必对该 VPLS 使用相同的路由区分符,因为路由区分符不用于确定某个 BGP NLRI 是否与特定 VPLS 相关(此用途使用路由目标属性),但不同 VPLS 必须具有不同的路由区分符。接受 3 种格式。阅读更多>> |
site-id | num | 唯一的站点标识符。每个站点必须具有唯一的 site-id。对于 RFC 4761 风格的 VPLS 信令,必须设置此参数。 |
cisco-id | address | 唯一标识符。对于 Cisco 风格的 VPLS 信令,必须设置此参数。大多数情况下不应使用此参数,任何现代软件都支持 RFC 4761 风格的信令(请参阅 site-id 参数)。该参数是 l2-router-id 和 RD 的合并,例如:10.155.155.1&6550:123 |
import-route-targets | multi { array-id, rt: address (flags=R) } | 此设置通过比较从 BGP NLRI 接收的路由目标,确定 BGP NLRI 是否与特定 VPLS 相关。 |
export-route-targets | multi { array-id, rt: address (flags=R) } | 此设置用于为一个或多个路由目标标记 BGP NLRI,远程侧由 import-route-targets 使用这些路由目标。 |
local-pref | num | |
interface-list | enum | |
pw-type | enum (tagged-ethernet | raw-ethernet | vpls) | 伪线类型(RFC 4447 第 5.2 节)。默认使用 raw-ethernet。 |
pw-l2mtu | num | 向远程对等点通告的 L2MTU 值(RFC 4447 第 5.2 节)。 |
pw-control-word | enum (default | enabled | disabled) | 启用或禁用控制字的使用(RFC 4623 第 4 节)。常规和 Cisco 风格 VPLS 隧道的默认值不同。Cisco 风格默认禁用控制字的使用。更多信息请阅读 VPLS 控制字文章。 |
bridge | iface_enum | VPLS 接口所属的网桥。 |
bridge-cost | num | 网桥端口的开销。 |
bridge-horizon | num | 设置为 none 时,不使用网桥 horizon。 |
bridge-pvid | num | 分配给动态桥接接口的端口 VLAN ID(pvid)。仅当网桥 vlan-filtering 设置为 yes 时适用。 |
| 只读参数 | 类型 | 描述 |
|---|---|---|
current-peers | string |