VPLS

本页介绍 MikroTik RouterOS 的 Virtual Private LAN Service(VPLS)接口,说明其作为透明以太网隧道的用途,以及 LDP 或 MP-BGP 协议。内容涵盖伪线等 VPLS 特性。

VPLS

Virtual Private LAN Service(VPLS)接口可视为与 EoIP 接口类似的隧道接口,用于在客户站点之间实现透明以太网段转发。

VPLS 隧道的协商可通过 LDP 协议或 MP-BGP 完成,隧道两端会交换将要用于该隧道的标签。

隧道中的数据转发通过在数据包上压入两个标签实现:隧道标签与传输标签,后者确保流量送达隧道的另一端点。

MikroTik RouterOS 实现以下 VPLS 功能:

  • VPLS LDP 信令(RFC 4762)。
  • Cisco 风格静态 VPLS 伪线(RFC 4447 FEC 类型 0x80)。
  • VPLS 伪线分片与重组(RFC 4623)。
  • 基于 VPLS MP-BGP 的自动发现与信令(RFC 4761)。
  • Cisco VPLS 基于 BGP 的自动发现(draft-ietf-l2vpn-signaling-08)。
  • 基于 BGP 的 VPLS 支持多个导入/导出 route-target 扩展团体(同时支持 RFC 4761 与 draft-ietf-l2vpn-signaling-08)。

VPLS 前提条件

为使 VPLS 能够传输 MPLS 数据包,骨干网中应已运行一种标签分发协议,可以是 LDP、RSVP-TE 或静态绑定。

继续之前,请先了解 LDP 所需前提条件 与 RSVP-TE 的前提条件。

如果使用 BGP 作为 VPLS 发现与信令协议,骨干网应运行 iBGP,最好配置路由反射器。

示例设置

假设我们已有一个可用的 LDP 设置,来自 LDP 配置示例。

路由器 R1、R3 和 R4 连接到客户 A 的站点,路由器 R1 和 R3 连接到客户 B 的站点。客户需要站点之间的透明二层连接。