WinBox v3 (Legacy)

WinBox v3 是一个用于管理 MikroTik RouterOS 的 GUI 工具,通过 Wine 支持 Linux/macOS。本旧版页面记录基于 Wine 的 WinBox v3——如需原生跨平台体验,请使用 WinBox v4。

WinBox v3 (Legacy)

警告

本页记录旧版 WinBox v3(基于 Wine)应用。MikroTik 现在提供 WinBox v4,一个适用于 Windows、Linux 和 macOS 的原生跨平台应用。当前版本请参阅 WinBox v4 文档。

WinBox 是一个小型工具,允许通过快速、简单的 GUI 管理 MikroTik RouterOS。它是一个原生 Win32/Win64 二进制文件,但可以通过 Wine 在 Linux 和 macOS (OSX) 上运行。所有 WinBox 界面功能都尽可能与 console 功能保持一致,这就是手册中没有 WinBox 章节的原因。某些高级和系统关键配置无法通过 WinBox 完成,例如更改接口的 MAC 地址。

从 WinBox v3.14 起,使用了以下安全功能:

  • WinBox.exe 由 SIA Mikrotīkls (MikroTik) 签发的 Extended Validation 证书签名。
  • WinBox 使用 ECSRP 进行密钥交换和认证(需要新的 WinBox 版本)。
  • 双方都会验证对方知道密码(不可能进行中间人攻击)。
  • WinBox 在 RoMON 模式下要求代理是最新版本,才能连接到最新版本的路由器。
  • WinBox 使用 AES128-CBC-SHA 作为加密算法(需要 WinBox v3.14 及更高版本)。

启动 WinBox

WinBox 加载器可从 MikroTik 下载页面 下载。下载 WinBox.exe 后,双击它,WinBox 加载器窗口就会弹出。WinBox 加载器有两种模式:simple(默认启用)和 advanced。

Simple 模式

首次打开 WinBox 加载器时,使用 simple 模式布局:

要连接到路由器,请输入路由器的 IP 或 MAC 地址,指定用户名和密码(如果有),然后选择 Connect 按钮。你也可以在 IP 地址后输入端口号,用冒号分隔,例如 192.168.88.1:9999。端口可以在 RouterOS services 菜单中更改。

警告

建议尽可能使用 IP 地址。MAC 会话使用网络广播,并非 100% 可靠。

你也可以使用邻居发现来列出可用的路由器。使用 Neighbors 标签页:

在已发现路由器的列表中,你可以选择 IP 或 MAC 地址列来连接到该路由器。如果你选择 IP 地址列,则使用 IP 连接;如果你选择 MAC 地址列,则使用 MAC 地址连接到路由器。

信息

邻居发现也会显示与 WinBox 不兼容的设备,例如 Cisco 路由器或任何使用 CDP (Cisco Discovery Protocol) 的其他设备。如果你尝试连接到 SwOS 设备,则会通过 Web 浏览器建立连接

按钮/复选框和其他字段

  • Connect - 连接到路由器。
  • Connect To RoMON - 连接到 RoMON Agent。
  • Add/set - 在 Managed 标签页中保存/编辑任何已保存的路由器条目。
  • Open In New Window - 让加载器在后台保持打开,并为每个连接的设备打开新窗口。
  • Connect To: - 路由器的目标 IP 或 MAC 地址。
  • Login - 用于认证的用户名。
  • Password - 用于认证的密码。
  • Keep Password - 如果未勾选,密码不会保存到列表。

菜单项

  • File

    • New - 在指定位置创建新的受管路由器列表
    • Open - 打开受管路由器列表文件
    • Save As - 把当前受管路由器列表保存到文件
    • Exit - 退出 WinBox 加载器
  • Tools

    • Advanced Mode - 启用/禁用 advanced 模式视图
    • Import - 导入已保存的会话文件
    • Export - 导出已保存的会话文件
    • Move Session Folder - 更改会话文件的存储路径
    • Clear cache - 清除 WinBox 缓存
    • Check For Updates - 检查 WinBox 加载器的更新

Advanced 模式

通过 Tools → Advanced Mode 启用 advanced 模式后,会显示额外的 WinBox 加载器参数:

按钮/复选框和其他字段

按钮/复选框

  • Browse - 浏览某个特定会话的文件目录。
  • Keep Password - 如果未勾选,密码不会保存到列表。
  • Secure mode - 如果勾选,WinBox 使用 DH-2048 进行密钥交换,并使用修改并加固的 RC4-drop3072 加密来保护会话。
  • Autosave session - 为建立连接的设备自动保存会话。

字段:

  • Session - 已保存的路由器会话。
  • Note - 分配给已保存路由器条目的备注。
  • Group - 已保存路由器条目所属的组。
  • RoMON Agent - 从可用设备列表中选择 RoMON Agent。

危险

Managed routers 列表是加密的,但如果未为其设置主密码,它仍然可以被另一个 WinBox 加载!

命令行

可以使用命令行自动传入 connect-to、user、password 和 session(WinBox 4 中的 "workspace")参数:

winbox.exe [<connect-to> [<login> [<password>]]] <session|workspace>]

例如(无密码):

winbox.exe 10.5.101.1 admin "" "<own>"

这会以用户 "admin"、无密码连接到路由器 10.5.101.1,并使用 session|workspace "<own>"。

可以使用命令行自动传入 connect-to、user 和 password 参数,通过 RoMON 连接到路由器。在这种情况下,RoMON Agent 必须保存在 Managed routers 列表中,以便 WinBox 知道该设备的用户名和密码:

winbox.exe --romon [<romon-agent> [<connect-to> [<login> [<password>]]] <session|workspace>]

例如(无密码):

winbox.exe --romon 10.5.101.1 D4:CA:6D:E1:B5:7D admin "" "<own>"

通过 10.5.101.1 使用 RoMON Agent,以用户 "admin"、无密码连接到路由器 D4:CA:6D:E1:B5:7D,并应用名为 "<own>" 的 session|workspace。

IPv6 连通性

WinBox 支持 IPv6 连通性。要连接到路由器的 IPv6 地址,必须像在 Web 浏览器中连接 IPv6 服务器时一样把它放在方括号中。示例:

[db8::1]

连接到链路本地地址时,接口索引必须输入在 % 之后:

[0:a00:27ff:fe70::e88c%2]

当需要把 WinBox 连接到非默认端口时,端口号写在方括号之后:

WinBox 邻居发现能够发现启用了 IPv6 的路由器。每台启用 IPv6 的路由器有两个条目,一个是 IPv4 地址,另一个是 IPv6 链路本地地址。你可以轻松选择要连接的那一个。

在 macOS 上运行 WinBox

从 macOS 10.15 Catalina 开始,Apple 移除了对 32 位应用的支持,这意味着在该操作系统中不再能使用常规 Wine 和常规 WinBox。Wine 为 macOS 提供了 64 位版本,MikroTik 也发布了特殊的 WinBox64.exe 版本。

运行 WinBox64 需要以下步骤:

  1. 从 Wine macOS builds 页面 安装最新的 Wine(wine-devel-7.X-osx64.tar.xz),并确保你已从 MikroTik 下载页面下载了 WinBox64.exe 可执行文件。
  2. 用 "open file with" > Wine64.app 启动 WinBox64.exe。

在 Linux 上运行 WinBox

可以使用 Wine 模拟软件在 Linux 上运行 WinBox。请确保安装了 Microsoft 字体包,否则你可能会看到显示变形。

界面概览

WinBox 界面的设计对大多数用户来说是直观的。界面由以下部分组成:

  • 顶部的主工具栏,用户可以在其中添加各种信息字段,例如 CPU 和内存使用率。
  • 左侧的菜单栏 - 所有可用菜单和子菜单的列表。该列表会根据已安装的软件包而变化。例如,如果 IPv6 包被禁用,则 IPv6 菜单及其所有子菜单都不会显示。
  • Work area - 打开所有菜单窗口的区域。

标题栏显示用于识别当前 WinBox 会话连接到哪台路由器的信息。信息以以下格式显示:

[username]@[Router's IP or MAC] ( [RouterID] ) - WinBox [ROS version] on [RB model] ([platform])

从截图中我们可以看到,用户 krisjanis 登录到 IPv4/IPv6 地址为 [fe80::4e5e:cff:fef6:c0ab%3] 的路由器。路由器 ID 是 3C18-Krisjanis_GW,当前安装的 RouterOS 版本是 v6.36rc6,RouterBoard 是 CCR1036-12G-4S,平台是 tile。

主工具栏左侧是:

  • Undo
  • Redo
  • Safe Mode
  • 当前加载的会话

关于 Safe mode 和撤销已执行操作的更多内容可在本文中阅读。

右侧是:

  • 一个指示 WinBox 会话是否使用加密的指示器。
  • 以绿色条显示的 WinBox 流量指示器。
  • 用户可以通过右键点击工具栏并从列表中选择可用信息字段来添加的自定义信息字段。

Work Area 与子窗口

WinBox 具有 MDI 界面,意味着所有菜单配置(子)窗口都附加到主(父)WinBox 窗口,并显示在 work area 中。

子窗口无法被拖出 work area。在截图中,Interface 窗口被拖出了可见的 work area,底部出现了水平滚动条。如果任何窗口超出可见 work area 的边界,就会出现垂直和/或水平滚动条。

子窗口菜单栏

每个子窗口都有自己的工具栏。大多数窗口都有相同的工具栏按钮集:

  • Add - 向列表添加新条目。
  • Remove - 从列表移除选中条目。
  • Enable - 启用选中条目(与 console 中的 enable 命令相同)。
  • Disable - 禁用选中条目(与 console 中的 disable 命令相同)。
  • Comment - 添加或编辑注释。
  • Sort - 允许你根据各种参数对条目排序。对显示的条目排序

几乎所有窗口在工具栏右侧都有一个快速搜索输入字段。在此字段中输入的任何文本都会在所有条目中搜索并高亮显示,如下图所示。

请注意,在快速查找输入字段右侧有一个下拉框。对于当前打开的 (IP Route) 窗口,此下拉框允许按路由表快速筛选条目。例如,如果选择 main,则只列出 main 路由表中的路由。 所有防火墙窗口中也有类似的下拉框,用于按 chain 快速筛选规则。

对显示的条目排序

几乎每个窗口都有一个 Sort 按钮。选择此按钮时,会出现几个选项,如下图所示。

该示例展示了如何快速筛选出位于 10.0.0.0/8 范围内的路由:

  1. 按 Sort 按钮。
  2. 从第一个下拉框中选择 Dst.Address。
  3. 从第二个下拉框中选择 in。"in" 表示过滤器检查 DST 地址值是否在指定网络的范围内。
  4. 输入用于比较值的网络(在我们的示例中输入 "10.0.0.0/8")。
  5. 这些按钮用于向堆栈中添加或移除另一个过滤器。
  6. 按 Filter 按钮应用我们的过滤器。

从截图中可以看到,WinBox 只筛选出了位于 10.0.0.0/8 范围内的路由。

比较运算符(截图中的数字 3)可能因窗口而异。例如,"IP Route" 窗口只有两个:is 和 in。其他窗口可能有 "is not"、"contains"、"contains not" 等运算符。

WinBox 允许构建过滤器堆栈。例如,如果需要按目的地址和网关过滤,则:

  • 按前一个示例所述设置第一个过滤器。
  • 按 [+] 按钮在堆栈中添加另一个过滤器栏。
  • 设置第二个过滤器以按网关过滤。
  • 按 Filter 按钮应用过滤器。

你也可以按 [-] 按钮从堆栈中移除不必要的过滤器。

定制显示列列表

默认情况下,WinBox 显示最常用的参数。但是,有时需要查看其他参数,例如 "BGP AS Path" 或其他 BGP 属性,以监控路由是否被正确选择。

WinBox 允许你为每个单独的窗口定制显示的列。例如,要添加 BGP AS path 列:

  • 选择列标题右侧的小箭头按钮 (1),或右键点击路由列表。
  • 在弹出菜单中移到 Show Columns (2),然后从子菜单中选择所需的列,在本例中选择 BGP AS Path (3)。

对窗口布局所做的更改会被保存,下次打开 WinBox 时会应用相同的列顺序和大小。

详细模式

也可以启用 Detail mode。在此模式下,所有参数都以列显示,第一列是参数名,第二列是参数值。

要启用详细模式,请右键点击条目列表并从弹出菜单中选择 Detail mode

分类视图

可以按类别列出条目。在此模式下,所有条目按字母顺序或按其他类别分组。例如,如果按名称排序,条目可以按字母顺序分类;条目也可以按类型分类,如下图所示。

要启用 Category view,请右键点击条目列表并从弹出菜单中选择 Show Categories。

拖放

可以使用 WinBox 拖放功能向/从路由器上传和下载文件。你也可以通过右键点击文件并选择 "Download" 来下载文件。

信息

如果 WinBox 使用 wine4 在 Linux 上运行,拖放可用。在两个 WinBox 窗口之间拖放可能会失败。

流量监控

WinBox 可以用作实时监控每个接口、队列或防火墙规则流量的工具。以下截图显示了以太网流量监控图表。

条目复制

这展示了在 WinBox 中复制条目有多么容易。在本例中,使用 COPY 按钮把动态 PPPoE 服务器接口变为静态接口。

此图显示了初始状态。如你所见,DR 表示 "D",意味着 Dynamic:

双击该接口并选择 COPY:

会出现一个新的接口窗口,并自动创建一个新名称(在本例中为 pppoe-in1)。

在此 Down/Up 事件之后,该接口变为 Static:

转移设置

  • 受管路由器转移 - 在 File 菜单中,使用 Save As 和 Open 功能把受管路由器列表保存到文件,并在新工作站上再次打开。

  • 路由器会话转移 - 在 Tools 菜单中,使用 Export 和 Import 功能把现有会话保存到文件,并在新工作站上再次导入。

WinBox v3 键盘快捷键

快捷键说明
<kbd>Control</kbd>+<kbd>F</kbd>查找
<kbd>Control</kbd>+<kbd>G</kbd>查找下一个
<kbd>F3</kbd>查找 / 查找下一个
<kbd>Control</kbd>+<kbd>M</kbd>添加或编辑注释
<kbd>Control</kbd>+<kbd>E</kbd> 或 <kbd>Num+</kbd>启用选中的设置
<kbd>Control</kbd>+<kbd>D</kbd> 或 <kbd>Num-</kbd>禁用选中的设置
<kbd>Control</kbd>+<kbd>+</kbd>放大 WinBox
<kbd>Control</kbd>+<kbd>-</kbd>缩小 WinBox
<kbd>Tab</kbd>选择下一个控件
<kbd>Tab</kbd>+<kbd>Shift</kbd>选择上一个控件
<kbd>Space</kbd>选中聚焦的控件
<kbd>F4</kbd> 或 <kbd>Esc</kbd>关闭窗口
<kbd>F6</kbd>聚焦上一个窗口
<kbd>F6</kbd>+<kbd>Shift</kbd>聚焦下一个窗口
<kbd>Insert</kbd>向列表添加新条目
<kbd>Delete</kbd>从列表删除条目

WinBox v4 键盘快捷键

快捷键说明
<kbd>Control</kbd>+<kbd>E</kbd>启用选中的设置
<kbd>Control</kbd>+<kbd>Shift</kbd>+<kbd>E</kbd>禁用选中的设置
<kbd>Control/CMD</kbd>+<kbd>+</kbd>放大 WinBox
<kbd>Control/CMD</kbd>+<kbd>-</kbd>缩小 WinBox
<kbd>Control/CMD</kbd>+<kbd>0</kbd>重置缩放
<kbd>Control</kbd>+<kbd>Tab</kbd>选择下一个标签页
<kbd>Control</kbd>+<kbd>Shift</kbd>+<kbd>Tab</kbd>选择上一个标签页
<kbd>Tab</kbd>选择下一个控件
<kbd>Shift</kbd>+<kbd>Tab</kbd>选择上一个控件
<kbd>Space</kbd>选中聚焦的控件
<kbd>Control</kbd>+<kbd>F4</kbd> 或 <kbd>Alt</kbd>/<kbd>Cmd</kbd>+<kbd>W</kbd>关闭窗口
<kbd>Alt</kbd>+<kbd>A</kbd> / <kbd>Cmd</kbd>+<kbd>Shift</kbd>+<kbd>S</kbd>聚焦上一个窗口
<kbd>Alt</kbd>/<kbd>Cmd</kbd>+<kbd>S</kbd>聚焦下一个窗口
<kbd>Delete</kbd>从列表删除条目
<kbd>Alt</kbd>/<kbd>Cmd</kbd>+<kbd>Opt</kbd>+<kbd>F</kbd>全局菜单搜索
<kbd>Alt</kbd>/<kbd>Cmd</kbd>+<kbd>T</kbd>打开新的 Terminal 窗口

故障排查

WinBox 无法连接到路由器的 IP 地址,设备不显示在 Neighbors 列表中

请确保 Windows 防火墙设置为允许通过 Private 和/或 Public 网络接口进行 WinBox 连接。这可以在 Control Panel\System and Security\Windows Defender Firewall\Allowed applications 中更改。或者禁用 Windows 防火墙。

连接到路由器 MAC 地址时我收到错误 '(port 20561) timed out'

如果文件与打印共享被禁用,Windows (7/8) 不允许 MAC 连接。

我在 WinBox IPv4 Neighbors 列表中找不到我的设备,或 MAC 连接失败并显示 "ERROR could not connect to XX-XX-XX-XX-XX-XX"

除非你的主机设备有 IP 配置,否则大多数网络驱动不会启用 IP 协议栈。请在主机设备上设置 IPv4 配置。

有时设备会因缓存而被发现,但 MAC 连接仍会失败并显示 "ERROR: could not connect to XX:XX:XX:XX:XX:XX"。

警告

WinBox MAC 地址连接要求 MTU 值设置为 1500,且不分片。其他值可能导致性能不佳——可能会发生连接丢失。