Understanding OSPF
OSPF 协议基础概述。
理解 OSPF
OSPF 是一种内部网关协议(IGP),旨在在同一自治系统(AS)内的路由器之间分发路由信息。
该协议基于链路状态技术,相较 RIP 等距离矢量协议具有若干优势:
- 没有跳数限制。
- 使用组播寻址发送路由信息更新。
- 仅在网络拓扑发生变化时发送更新。
- 通过将路由器划分为 area 来逻辑地定义网络。
- 注入到 AS 中的外部路由会被传递并打上标记。
不过,OSPF 也有一些缺点:
- OSPF 占用大量 CPU 和内存,因为 SPF 算法必须维护多份路由信息副本。
- 实现起来比 RIP 更复杂。
术语
请阅读以下术语以理解 OSPF 的工作方式。你将在整个文档中遇到这些术语。
- Neighbor:运行 OSPF 且相邻接口分配到同一 area 的已连接(相邻)路由器。除非手动配置邻居,否则由 Hello 数据包发现邻居。
- Adjacency:路由器与其对应的 DR 和 BDR 之间的逻辑连接。除非形成邻接关系,否则路由器不会交换路由信息。
- Link:分配到任意给定网络的网络或路由器接口。
- Interface:路由器上的物理接口。当你将接口添加到 OSPF 时,它就成为用于构建链路数据库的 link。
- LSA:Link State Advertisement(链路状态通告),一种携带链路状态和路由信息的数据包,在 OSPF 邻居之间共享。
- DR:Designated Router(指定路由器),为最小化所形成的邻接关系数量而选出的路由器。OSPF 在广播网络中使用此选项。
- BDR:Backup Designated Router(备份指定路由器),DR 的热备用。BDR 接收来自相邻路由器的所有路由更新,但不泛洪 LSA 更新。
- Area:用于建立层次化网络的逻辑分组。
- ABR:Area Border Router(区域边界路由器),连接到多个 area 的路由器。ABR 负责所连接 area 之间的汇总和更新抑制。
- ASBR:Autonomous System Boundary Router(自治系统边界路由器),连接到外部网络(位于不同 AS)的路由器。当你在某台路由器上将来自其他协议的路由导入 OSPF 时,该路由器就成为 ASBR。
- NBMA:Non-broadcast multi-access networks(非广播多路访问网络)。这些网络允许多路访问,但不具备广播能力。你必须在这类网络上手动配置 OSPF 邻居。
- Broadcast:具有广播能力的网络。例如以太网。
- Point-to-point:不需要 DR 和 BDR 的网络类型。
- Router-ID:用于标识 OSPF 路由器的 IP 地址。如果你没有手动配置 OSPF
router-id,路由器将使用其已分配 IP 地址之一作为 Router-ID。 - Link State:两台路由器之间链路的状态。它定义路由器接口与其相邻路由器之间的关系。
- Cost:由链路状态协议分配给每条链路的值。
cost值取决于介质的速率。每个路由器接口在其输出侧都有一个关联的 cost,称为接口输出 cost。 - Autonomous System:使用公共路由协议来交换路由信息的一组路由器。
支持的标准
- RFC 2328 - OSPF Version 2
- RFC 3101 - The OSPF Not-So-Stubby Area (NSSA) Option
- RFC 3630 - Traffic Engineering (TE) Extensions to OSPF Version 2
- RFC 4577 - OSPF as the Provider/Customer Edge Protocol for BGP/MPLS IP Virtual Private Networks (VPNs)
- RFC 5329 - Traffic Engineering Extensions to OSPF Version 3
- RFC 5340 - OSPF for IPv6
- RFC 5643 - Management Information Base for OSPFv3
- RFC 6549 - OSPFv2 Multi-Instance Extensions
- RFC 6565 - OSPFv3 as a Provider Edge to Customer Edge (PE-CE) Routing Protocol
- RFC 6845 - OSPF Hybrid Broadcast and Point-to-Multipoint Interface Type
- RFC 7471 - OSPF Traffic Engineering (TE) Metric Extensions