VPLS
VPLS 页面介绍 MikroTik RouterOS 的 Virtual Private LAN Service(VPLS)接口,详细说明其作为使用 LDP 或 MP-BGP 协议的透明以太网隧道的用途。内容涵盖 VPLS 的伪线信令、分片以及基于 BGP 的自动发现等功能,以及 MPLS 标签分发的前置条件和 i
VPLS
Virtual Private LAN Service(VPLS)接口可以像 EoIP 接口一样被视为隧道接口,用于在客户站点之间实现透明的以太网段转发。
VPLS 隧道的协商可以通过 LDP 协议或 MP-BGP 完成——隧道的两个端点交换它们将用于该隧道的标签。
隧道中的数据转发通过对数据包压入 2 个标签来实现:隧道标签和传输标签——后者确保流量被送达隧道的另一个端点。
MikroTik RouterOS 实现以下 VPLS 功能:
- VPLS LDP 信令(RFC 4762)。
- Cisco 风格的静态 VPLS 伪线(RFC 4447 FEC type 0x80)。
- VPLS 伪线分片与重组(RFC 4623)。
- 基于 VPLS MP-BGP 的自动发现与信令(RFC 4761)。
- Cisco VPLS 基于 BGP 的自动发现(draft-ietf-l2vpn-signaling-08)。
- 支持基于 BGP 的 VPLS 使用多个导入/导出 route-target 扩展团体(RFC 4761 和 draft-ietf-l2vpn-signaling-08 皆支持)。
VPLS 前置条件
要让 VPLS 能够传输 MPLS 数据包,骨干网上应已运行其中一种标签分发协议;它可以是 LDP、RSVP-TE 或静态绑定。
在继续之前,请先熟悉 LDP 所需的前置条件以及 RSVP-TE 的前置条件。
如果要将 BGP 用作 VPLS 发现和信令协议,骨干网应运行 iBGP,最好配有一个或多个路由反射器。
示例配置
假设我们已经有来自 LDP 配置示例的可正常工作的 LDP 配置。
路由器 R1、R3 和 R4 连接到客户 A 的站点,路由器 R1 和 R3 连接到客户 B 的站点。客户需要在站点之间实现透明的二层连通性。