MPLS

MPLS 是一种使用标签进行更快速数据包转发的路由技术,它取代了对 IP 头的分析。RouterOS 支持 MPLS 交换、LDP/RSVP-TE 协议、VPLS 和 MP-BGP VPN,但不包含某些 LDP/TE 功能。

MPLS 代表 MultiProtocol Label Switching(多协议标签交换)。MPLS 不使用 IP 路由,而是根据附加在数据包上的标签(而非 IP 头中的字段,例如目的地址)和路由表来决定数据包转发(出接口和下一跳路由器)。这种方法加快了转发过程,因为下一跳查找比路由查找(查找最长匹配前缀)更简单。

转发过程的效率是 MPLS 的主要优势。但是请记住,MPLS 转发会禁用网络层(例如 IP)头的处理。因此,你无法对 MPLS 转发的数据包应用基于网络层的操作,例如 NAT 和过滤。请将任何基于网络层的操作施加在 MPLS 云的入口或出口处,入口是首选方式。这样,你打算丢弃的流量就不会穿过 MPLS 骨干网。

MPLS 的工作方式是通过 LDP 协议为活动路由分发标签,带标签的数据包会走与无标签数据包相同的路径。当路由器沿某条路由转发无标签数据包,而它已从下一跳收到该路由的标签时,它会为数据包压入一个标签并发送给下一跳,下一跳处的 MPLS 会将其沿路径继续交换。当路由器收到一个带有它分配给某条特定路由的标签的数据包时,它会用从该路由下一跳收到的标签替换数据包标签,并将数据包发送给下一跳。标签交换路径确保数据被送达 MPLS 云的出口点。MPLS 应用正是基于这种标签交换路径的概念。

建立标签交换路径的另一种方式是使用 RSVP-TE 协议的流量工程隧道(TE 隧道)。流量工程隧道允许显式路由的 LSP 和基于约束的路径选择(约束是接口属性和可用带宽)。

由于 MPLS 引入了复杂性、新协议,并为路由网络和桥接网络增加了不同的概念,因此在生产网络中部署 MPLS 之前,你应该深入理解 MPLS 概念。一些建议阅读的资料:

信息

SMIPS 设备(hAP lite、hAP lite TC 和 hAP mini)不支持此功能。

支持的功能

RouterOS 支持以下 MPLS 相关功能:

  • 支持倒数第二跳弹出的 MPLS 交换。
  • 面向 IPv4 和 IPv6 的静态本地标签绑定。
  • 面向 IPv4 和 IPv6 的静态远程标签绑定。
  • 面向 IPv4 和 IPv6 的 Label Distribution Protocol(RFC 3036、RFC 5036 和 RFC 7552):
    • 下游主动标签通告。
    • 独立标签分发控制。
    • 自由标签保留。
    • 定向会话建立。
    • 可选环路检测。
    • ECMP 支持。
  • Virtual Private LAN Service(VPLS):
  • RSVP-TE 隧道:
    • 隧道头端。
    • 显式路径。
    • 面向 TE 隧道的 OSPF 扩展。
    • CSPF 路径选择。
    • 在 TE 隧道上转发 VPLS 和 MPLS IP VPN 流量。
    • 入口 TE 隧道速率限制和自动保留带宽调整。更多信息,请参见 Traffic Eng。
    • 所有隧道带宽设置均以比特每秒为单位指定和显示。
  • 基于 MP-BGP 的 MPLS IP VPN。
  • 基于 MP-BGP 的 MPLS VPN 的按前缀和按 VRF 标签分发策略。
  • 面向 MPLS TE 的 OSPF 扩展。
  • 支持将 OSPF 作为 CE-PE 协议。
  • 针对指定 VRF 的 ping 和 traceroute。
  • 控制 MPLS 中网络层 TTL 的传播。
  • 将 RIP 作为 CE-PE 协议。
  • 按 VRF 的 BGP 实例重分发设置。

RouterOS 尚不具备的 MPLS 功能

  • LDP 功能:
    • 下游按需标签通告。
    • 有序标签分发控制。
    • 保守标签保留。
  • TE 功能:
    • 快速重路由。
    • 链路/节点保护。
  • 支持将 BGP 作为标签分发协议。