“WireGuard 隧道” 的检索结果

共 30 个相关页面

中Virtual Private Networks
虚拟专用网络 (VPN) / 虚拟专用网络 — # 虚拟专用网络 VPN 文档涵盖 RouterOS 隧道与 VPN 技术,包括 IPsec、L2TP、PPPoE、PPTP、SSTP、OpenVPN、WireGuard、GRE、EoIP、IPIP、6to4 和 ZeroTier。可使用本节配置安全或封装连接。
中WireGuard
虚拟专用网络 (VPN) — > WireGuard 是一种现代 VPN 解决方案,提供跨平台的快速、安全加密,并具备详细的配置选项,包括私钥/公钥、VRF 路由和 peer 管理,用于在设备之间建立加密隧道。
中/interface/wireguard/wg-import
CLI 命令参考 / wg-import — # wg-import > /interface/wireguard/wg-import 的 RouterOS 命令参考。 -----------
中/interface/wireguard/wg-export
CLI 命令参考 / wg-export — # wg-export > 以标准 WireGuard 配置格式导出所选 WireGuard 接口及其对等体。使用 `[find name=...]` 选择接口。导出不包含接口 IP 地址、路由或防火墙规则。如需可执行的 RouterOS 脚本,请使用常规的 `/interface/wireguard/export` 命令。参见 [WireGuard](../../../virtual-private-networks/wireguard)...
中L2TP
虚拟专用网络 (VPN) / 概述 — ### 概述 第二层隧道协议版本 3(L2TPv3)由互联网工程任务组(IETF)的 [RFC 3931](https://tools.ietf.org/html/rfc3931) 定义。它对原始 L2TP 进行了多项改进,允许在 L2TP 中封装二层(L2)载荷,用于二层虚拟专用网络(VPN)。L2TP Ether 隧道在两个端点之间传输原始以太网帧(以太网伪线,Pseudowire-Type 5)。 要建立 L2TP Ether 隧道,必须在客户端侧创...
中Back To Home
网络服务 / Back To Home — - 作为所有者,连接到你的 BTH 隧道。 - 点击隧道旁的 "..." 图标,然后点击 "Manage shares"。 - 输入路由器的管理员密码,因为你将修改路由器配置。 - 在 Shares 管理器中点击 "Create"。 - 在 "Tunnel name" 中输入你朋友的名字,因为将为他们创建一个新隧道。 - 指定这个新访客隧道的到期日期。 - 指定该用户是否需要访问你的家庭内部网络。如果他们只想使用此隧道访问互联网,请勿勾选此项。 - 按下 "Create ...
中EVPN
路由与网络协议 / EVPN — # EVPN 以太网虚拟专用网络(EVPN)是一种在不同网段之间扩展二层和三层连接的技术。MPLS 或 VXLAN 封装通过基于 MPLS 或 IP 的网络传输以太网帧。 BGP EVPN 用作多种数据平面封装(二层和三层 VPN 服务)的控制平面。MP-BGP 承载 MAC 地址、MAC/IP 绑定以及 IP 前缀。 RFC7432 是最初的 EVPN 标准,它定义 BGP 作为 MPLS 数据平面的控制平面。RFC8365 扩展了对其他数...
中L2TP
虚拟专用网络 (VPN) / 概述 — ...c3931) 定义。它对原始 L2TP 引入了多项改进,允许在 L2TP 内封装二层 (L2) 有效载荷,以用于 L2 虚拟专用网络 (VPN)。L2TP Ether 隧道在两个端点之间传输原始以太网帧(一种以太网伪线,Pseudowire-Type 5)。 要建立 L2TP Ether 隧道,必须在客户端侧创建 L2TP Ether 接口,同时在远端(服务器)侧启用 L2TP 服务器。正确配置两侧后,它们之间会自动创建一个动态接口,在 IP 网络上形成透明的二层连接。 L2TP Ether 可以通过 UDP 封装(`l2tp-proto-version...
中Software Specifications
快速上手 / VPN — ## VPN - [IPSec](../../virtual-private-networks/ipsec/index.md):隧道与传输模式、证书或 PSK、AH 与 ESP 安全协议。 - IKEv2 支持。 - IPSec 的 AES-NI 硬件加速支持。 - 点对点隧道([OpenVPN](../../virtual-private-networks/openvpn.md)、[PPTP](../../virtual-private-n...
中Software Specifications
快速上手 / VPN — ## VPN - [IPSec](../../virtual-private-networks/ipsec/index.md) —— tunnel 和 transport 模式,证书或 PSK,AH 和 ESP 安全协议。 - 支持 IKEv2。 - IPSec 支持 AES-NI 硬件加速。 - 点对点隧道([OpenVPN](../../virtual-private-networks/openvpn.md)、[PPTP](../../v...
中Virtual Private Networks
虚拟专用网络 (VPN) / Virtual Private Networks — # Virtual Private Networks VPN 文档涵盖 RouterOS 隧道和 VPN 技术,包括 IPsec、L2TP、PPPoE、PPTP、SSTP、OpenVPN、WireGuard、GRE、EoIP、IPIP、6to4 和 ZeroTier。使用本节可配置安全或封装式的连接。
中Introduction
introduction / 文档的组织方式 — ...级与基础安全。 - 后续主题章节各自聚焦系统的一个领域:管理工具、系统信息与工具、诊断与监控、硬件、有线与无线连接、移动网络、桥接与交换、网络服务、路由协议、防火墙与服务质量、虚拟专用网络、用户管理、高可用、物联网、存储与容器。 - **开发者指南** 面向自动化 RouterOS 的人员,介绍脚本与编程接口。 - **CLI 参考** 位于最后,作为查询章节而非阅读章节。 如果设备对你来说是全新的,请从快速上手开始。基础系统就绪后,转到与任务匹配的主题章节。请将 CLI 参考视为工作过程中查阅的字典,而非从头读到尾的章节。
中/ip/cloud/back-to-home-user
CLI 命令参考 / back-to-home-user — # back-to-home-user > Back To Home 用户。每个用户都是 `back-to-home-vpn` 接口的 WireGuard 客户端,拥有自己的密钥和地址,路由器会为其添加动态对等点。Back To Home 应用会为它建立的每个隧道创建一个用户:`name` 是手机的型号标识符,例如 `iPhone18,1`,注释是应用中显示的隧道名称。多个用户可以具有相同的名称。[`show-client-config`](show-client-config) 会打印用户的客户端配置。仅在 Back To Home 运行(`vpn-...
中CHR: Hetzner Cloud Installation
快速上手 / 概述 — ...er Cloud](https://www.hetzner.com/cloud)** 是一个云计算平台,提供可弹性伸缩的虚拟机基础设施以及一系列预配置的 Linux 发行版。对于需要高级网络功能的用户,Hetzner Cloud 也是部署 **RouterOS Cloud Hosted Router(CHR)** 的合适平台。 Cloud Hosted Router(CHR)是专为 x86_64 虚拟化环境设计的 MikroTik RouterOS 版本。它提供与 MikroTik 硬件设备相同的核心路由、防火墙、VPN 和管理功能,适用于云端组网、VP...
中/interface/wireguard
CLI 命令参考 / interface/wireguard — ## interface/wireguard **Type:** Directory [WireGuard](../../../virtual-private-networks/wireguard) creates encrypted IP tunnels between peers identified by public keys. <ArgTable c1="标志" c2="名称" c3="描述"> <ArgTableRow arg="X" typ="di...
中GRE
虚拟专用网络 (VPN) / GRE — # GRE Generic Routing Encapsulation (GRE) 是一种隧道协议,最初由 Cisco 开发,用于在 IP 网络上封装各种网络层协议。它在隧道端点之间创建虚拟点对点链路,允许不同的协议流量通过路由式基础设施传输。 GRE 作为无状态隧道运行,其行为与 IPIP 和 EoIP 类似。由于端点之间不维护会话状态,即使远端变得不可达,流量仍会继续被转发到该远端。这可能导致流量被黑洞,直到路由重新收敛或隧道状态发生变化。 在 RouterOS 中,GRE 接口实现为虚拟接口,可根据所需的拓扑用于路由式...
中CHR: Proxmox VE Installation
快速上手 / 概述 — ## 概述 Cloud Hosted Router(CHR)是 MikroTik RouterOS 面向 x86_64 虚拟化环境设计的版本。它提供完整的路由、防火墙、VPN 和管理功能,适用于本地部署以及 Proxmox VE 等云端虚拟化基础设施。 Proxmox VE(KVM/QEMU)支持使用 raw 或 qcow2 磁盘镜像灵活部署 CHR,并提供多种存储后端和网络适配器选项。
中/interface/wireguard/peers
CLI 命令参考 / interface/wireguard/peers — ## interface/wireguard/peers **Type:** Directory <ArgTable c1="标志" c2="名称" c3="描述"> <ArgTableRow arg="X" typ="disabled">项目是否已禁用。</ArgTableRow> <ArgTableRow arg="D" typ="dynamic">对等体是否由系统动态创建。</ArgTableRow> </ArgTable>
中CHR: VirtualBox Installation
快速上手 / Network — ### Network - Adapter 1: - 启用网络适配器 - 连接到 **Bridged Adapter** 或 **NAT**(取决于你的环境) ![](./img/chr_install_virtualbox_07.png)
中Netinstall
快速上手 / 准备 Netinstall 主机 — ...重装设备处于同一二层(L2)网段的计算机或 MikroTik 路由器上启动 Netinstall。为获得最佳效果,请使用专用网络接口以及简单的交换机或集线器,避免 IP、DHCP 或 BOOTP 冲突。
中EoIP
虚拟专用网络 (VPN) / EoIP — # EoIP Ethernet over IP (EoIP) 隧道是 MikroTik RouterOS 的一种协议,用于在 IP 网络上的两台路由器之间创建以太网隧道。它基于 GRE 封装(RFC 1701),允许以太网帧通过路由式 IP 基础设施传输,从而在远程站点之间有效扩展二层网络。 EoIP 隧道接口在 RouterOS 中表现为虚拟以太网接口,可以与桥接功能配合使用。当添加到网桥后,所有以太网流量(包括广播和非 IP 协议)都会通过隧道转发,如同两个端点由物理以太网链路直接相连。 Eo...
中CHR: Installation
快速上手 / 虚拟网络适配器 — ### 虚拟网络适配器 :::info **Fast Path 支持情况** - RouterOS v7:**vmxnet3** 和 **virtio-net** 接口支持 Fast Path。 - RouterOS v6:不支持 Fast Path。 :::
中CHR: Installation
快速上手 / 虚拟网络适配器 — ### 虚拟网络适配器 :::info **Fast Path 支持** - RouterOS v7:使用 **vmxnet3** 与 **virtio-net** 接口时支持 Fast Path。 - RouterOS v6:不支持 Fast Path。 :::
中Quick Set
管理工具 / VPN — ### VPN 如果你想从互联网访问本地网络(以及你的路由器),请使用安全的 VPN 隧道。该选项为你提供用于连接的域名,并启用 [PPTP](../virtual-private-networks/pptp) 和 [L2TP/IPsec](../virtual-private-networks/l2tp)(推荐后者)。用户名为 'vpn',你可以指定自己的密码。你只需在此处启用它,然后在你的笔记本电脑或手机上提供地址、用户名和密码;连接到 V...
中VRRP
高可用方案 / 虚拟路由器(VR) — ## 虚拟路由器(VR) 虚拟路由器(VR)由一台 Owner 路由器和一台或多台属于同一网络的备份路由器组成。 VR 包含: - 在每个 VRRP 路由器上配置 VRID。 - 在每台路由器上配置相同的虚拟 IP。 - 在每台路由器上配置 Owner 和 Backup。对于给定的 VR,只能有一个 Owner。
中Securing your router
快速上手 / 保护设备访问 — ...非你完全理解其后果,否则不要删除这些规则。** :::danger[不要将管理服务暴露到互联网] 管理接口对互联网开放的网络设备会不断被自动化攻击扫描和针对。把 WinBox、SSH 或其他管理服务直接暴露到互联网可能导致: - 针对登录凭据的**暴力破解攻击**。 - 利用未修补的 RouterOS 版本中的**已知漏洞**。 - **设备被完全攻陷**——攻击者可以拦截流量、重定向 DNS、安装恶意软件,或把路由器作为进一步攻击的代理。 如果你需要远程访问设备,请**使用 VPN**(如 [WireGuard](../virtual-private-...
中OpenVPN
虚拟专用网络 (VPN) / OpenVPN — # OpenVPN OpenVPN 是一种基于 SSL/TLS 安全模型的 VPN 协议,广泛用于在不受信任的网络上提供安全的远程访问和站点到站点连接。它同时支持二层和三层隧道模式,可根据部署需求传输以太网帧或路由式 IP 流量。 OpenVPN 同时支持 IPv4 和 IPv6 流量,并且可以运行在多种网络拓扑中。 OpenVPN 可在多种平台上使用,包括 Linux、Windows、macOS 和其他操作系统。其配置结构在各平台上基本一致,从而...
中Bonding Examples
高可用方案 / 通过两条无线链路绑定 EoIP 隧道 — ## 通过两条无线链路绑定 EoIP 隧道 这是一个将多个网络接口聚合为单条管道的示例。具体来说,展示了如何聚合多个虚拟(EoIP)接口以获得最大吞吐量(MT),并着重于可用性。
中ZeroTier
虚拟专用网络 (VPN) / ZeroTier — # ZeroTier [ZeroTier](https://docs.zerotier.com/) 网络虚拟机管理器是一个自包含的网络虚拟化引擎,它实现了一个类似于 VXLAN 的以太网虚拟化层,构建在加密安全的全球点对点网络之上。它提供与企业 SDN 交换机相当的高级网络虚拟化和管理能力,但可跨越局域网和广域网,并连接几乎任何类型的应用或设备。 MikroTik 已在 RouterOS v7.1rc2 中将 ZeroTier 作为面向 **ARM/ARM64** 架构的独立软件包添加。
中IPIP
虚拟专用网络 (VPN) / IPIP — # IPIP IPIP (IP-in-IP) 是 RFC 2003 中定义的一种简单隧道协议,它将 IP 数据包封装在另一个 IP 头中,以在两个端点之间传输流量。在 RouterOS 中,IPIP 可用于跨中间 IP 网络在路由器之间创建点对点隧道。 IPIP 隧道接口在接口列表中表现为虚拟接口,可以像其他逻辑接口一样进行配置。该协议受到多种网络平台的支持,包括 RouterOS、Linux 和 Cisco 设备,从而实现不同厂商之间的互操作。 IPIP 通常用于通过公共或私有 IP 基础设施连接远程网络,而无需直接...