/interface/vpls
当前显示英文原文,切换到「中文」可查看译文。
vpls
List of all VPLS interfaces. This menu also shows dynamically created BGP-based VPLS interfaces.
interface/vpls
Conditions: !smips Type: Directory
List of all VPLS interfaces. This menu also shows dynamically created BGP-based VPLS interfaces.
| Flag | Name | Description |
|---|---|---|
X | disabled | disabled |
R | running | running |
D | dynamic | dynamic |
B | bgp-signaled | bgp-signaled |
C | cisco-bgp-signaled | cisco-bgp-signaled |
| Argument | Type | Description |
|---|---|---|
name | string | Name of the interface. |
mtu | num | Layer 3 Maximum Transmission Unit. |
mac-address | macAddr | Static MAC address of the interface. Automatically generated when not set. |
arp | enum (disabled | enabled | proxy-arp | reply-only | local-proxy-arp) | Address Resolution Protocol. |
arp-timeout | alt { arp-timeout: enum (auto) { auto:0 } , arp-timeout: time } | Time until an ARP entry expires. Set to auto to use the interface-type default value. |
disable-running-check | bool | Specifies whether to detect if an interface is running. If set to no, the interface will always have the running flag. |
peer * | address (flags=46v) | The IP address of the remote peer (RFC 4762 Section 3.1). |
vpls-id | address (flags=R) | A unique number that identifies the VPLS tunnel. Encoding is a 2byte+4byte or 4byte+2byte number (RFC 4762 Section 3.2). |
cisco-static-id | num | Cisco-style VPLS tunnel ID (RFC 4447 FEC type 0x80). |
pw-type | enum (tagged-ethernet | raw-ethernet | vpls) | Pseudowire type (RFC 4447 Section 5.2). By default, raw-ethernet is used. |
pw-l2mtu | num | L2MTU value advertised to a remote peer (RFC 4447 Section 5.2). |
pw-control-word | enum (default | enabled | disabled) | Enables or disables Control Word usage (RFC 4623 Section 4). Default values for regular and Cisco-style VPLS tunnels differ. Cisco-style by default has Control Word usage disabled. Read more in the VPLS Control Word article. |
bridge | iface_enum | Bridge the VPLS interface belongs to. |
bridge-cost | num | Cost of the bridge port. |
bridge-horizon | num | When set to none, bridge horizon is not used. |
bridge-pvid | num | Port VLAN ID (pvid) assigned to a dynamically bridged interface. Applies only when bridge vlan-filtering is set to yes. |